Cannabis/Paraphernalia mixed order fail to report to Metrc
Incident Report for Greenbits
Resolved
This incident has been resolved.
Posted Sep 05, 2022 - 14:15 PDT
Investigating
We are currently investigating this issue.
Posted Sep 05, 2022 - 13:36 PDT
This incident affected: Green Bits Reporting Service and Traceability (Metrc Colorado, Metrc Maryland, Metrc Alaska, Metrc Oregon, Metrc Nevada).