GreenBits backoffice is experiencing issues printing from the Back Office
Incident Report for Greenbits
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 20:54 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 15, 2024 - 20:51 PST
Investigating
We are currently investigating this issue.
Posted Feb 15, 2024 - 19:54 PST
This incident affected: Back Office.