www.greenbits.com homepage is down
Incident Report for Greenbits
Resolved
This incident is now resolved. www.greenbits.com is restored and users may use the page to log into Back Office again.
Posted Mar 31, 2022 - 10:11 PDT
Investigating
We are aware of an issue where users cannot log into the Back Office via www.greenbits.com. We are currently investigation the cause of this issue. Customers can still log in to the Back Office via secure.greenbits.com. We will provide additional updates as they become available.
Posted Mar 31, 2022 - 08:30 PDT