Issue scanning ID's
Incident Report for Greenbits
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 16:46 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 19, 2024 - 11:42 PST
Investigating
We are aware of an issue scanning ID's. The team is actively working to address it.
Posted Feb 19, 2024 - 11:41 PST