2/3/21 Back Office Slowness
Incident Report for Greenbits
Resolved
A fix to solve the issues causing slowness in the back office has been implemented and we've monitored the improvements. Moving this incident to resolved.
Posted Feb 03, 2021 - 18:36 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2021 - 16:50 PST
Investigating
We are currently investigating reports of Back office Slowness. We'll provide an update as soon as one is available.
Posted Feb 03, 2021 - 16:03 PST
This incident affected: Back Office.